
 

 
 
 
 

 
 
 
STOCKBOOK 

 

QUICK START GUIDE 
  
 
 
 
 
 

 
 
 
 
 
 

Livestock Management Software for Farmers to 
Work Smarter 



Stockbook 
 

© <2019> ... Practical Systems 

 
 

All rights reserved. No parts of this work may be reproduced in any form or by any means - graphic, electronic, or 
mechanical, including photocopying, recording, taping, or information storage and retrieval systems - without the 
written permission of the publisher. 

 
Products that are referred to in this document may be either trademarks and/or registered trademarks of the 
respective owners. The publisher and the author make no claim to these trademarks. 

 
While every precaution has been taken in the preparation of this document, the publisher and the author assume no 
responsibility for errors or omissions, or for damages resulting from the use of information contained in this document 
or from the use of programs and source code that may accompany it. In no event shall the publisher and the author be 
liable for any loss of profit or any other commercial damage caused or alleged to have been caused directly or 
indirectly by this document. 

 

 
 
 
 
 
 
 
 
 
 
 

Publisher 
 

Practical Systems 
 
 
 
 
 
 
 
 
 

Production 

Support Team 



1 

© <2018> … Practical Systems 

 

 

 
 

Quick Start Guide Contents 
 
1 New Users......................................................................................................................................3 
 

    1.1 How to Install Stockbook..........................................................................................................3 
 

1.2 Registration .....................................................................................................................7 
 

2 Finding help when you need it .........................................................................................................8 
 

2.1 On Screen Help .......................................................................................................................9 
 

2.2 Demonstration Data.................................................................................................................9 
 

2.3 Practical Systems Software Support Desk. ...............................................................................9 
 

3 Getting Started.................................................................................................................................10 
 

3.1 Options for Initial Stockbook Setup .........................................................................................11 
 

Option One - Use the Setup Wizard ................................................................................................11 
 

Option Two - Entering setup information using the setup menus ...................................................15 
 

3.2 Setup Backup Preferences .......................................................................................................16 
 

3.2.1 Data Warehouse Setup ........................................................................................................17 
 

     3.3       The Setup Menus...................................................................................................................19 
 

3.3.1 Setup Mobs........................................................................................................................19 
 

3.3.2 Set up Groups ....................................................................................................................20 
 

3.3.3 Setup Properties.................................................................................................................21 
 

3.3.4 Setup Paddocks..................................................................................................................21 
 

3.3.5 Setup Treatments ...............................................................................................................23 
 

Animal Treatments ........................................................................................................................23 
 

Paddock Treatments ......................................................................................................................24 
 

3.3.6 Setup Products ...................................................................................................................25 
 

3.3.7 Setup Veterinary Activities ...............................................................................................26 
 

3.3.8 Setup Cost Events..............................................................................................................27 
 

3.4 Setup User Options...............................................................................................................27 
 

3.5 Backing Up...............................................................................................................................29 
 

3.6 Restoring a Backup ..................................................................................................................31 
 

4 Adding your animals Into Stockbook.............................................................................................33 
 

4.1 Manually Adding Animals into Stockbook ............................................................................33 
 

4.2 Using the Add button ............................................................................................................34 
 

4.3 Using the Add Animal Wizard ..............................................................................................34 
 

4.4 Using the Multi-Add ..............................................................................................................35 



2 

© <2018> … Practical Systems 

 

 

 
 

4.5 Methods for Entering Animals Into Stockbook.....................................................................36 
 

4.6 Animal Types ........................................................................................................................37 
 

5 Additional Setup for Stud Users................................................................................................38 
 

5.1.1 Society and Stud Setup for Stud Cattle ................................................................................. 38 
 

5.1.2 Setup Performance Recording for Cattle........................................................................... 40 
 

5.2 Flock and Performance Recording Setup for Stud Sheep……………………………………….……………41 
 

5.2.1 Setup Flock Details.................................................................................................................42  
 

5.2.2 Setup Flock Society Details................................................................................................... 42 
 

5.2.3 Setup Performance Recording for Sheep ............................................................................... 44 
 
 
 
 
 
 
 

 
For more detailed instructions, please refer to the PS KNOWLEDGE BASE 

which can be accessed via the Practical Systems website home page 

https://support.practicalsystems.com.au/. 



3 

© <2018> … Practical Systems 

 

 

 
 

Stockbook Quick Start Guide 
 

The hardest part about using new software is getting started. This Quick Start Guide offers the 

quick way to begin using and understanding Practical Systems Stockbook. 

 

Quick Start Guide Icons 
 
 Learn a bit 

 

 Do a bit


 Important information





1 New Users 
 
1.1 How to Install Stockbook 

 

 There are two ways to install our programs: 

(1)   Go to the Practical Systems website   www.practicalsystems.com.au 

 Click on Client Support > Client Downloads menu options. 

 

 
 

 This will take you to the Client Login page. 

 Enter your Practical Systems Client ID and Password (not case sensitive), then click on the 
Login button. (Note: Password is usually the account holder’s first name). 

 Once the Software Downloads page has loaded, click on the Stockbook link which is located 
below the PS Stockbook icon. 

 

 

 

 

http://www.practicalsystems.com.au/
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 Click on the Run button: 

 

 
 

 

 Click Yes to the message:  ‘Do you want to allow the following program to make changes to this 
computer? 

 Follow the prompts (see below) to complete the INSTALLATION PROCESS. 
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(2)   Install from the installation disk. 

 Insert the Installation CD into your CD drive. 

 The CD will run automatically and open the installation screen. 

Use your mouse to: 
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 Click on the green button once, to select the Install Practical Systems Software option.  

 
 

 Click on the green button once, to select the Stockbook Suite option.  

 
 

 Click on the green button once, to select the Stockbook Installation option. 

 
 Follow the prompts (see previous page) to complete the INSTALLATION PROCESS. 

 

When installation process is complete: 

 Once the software has been installed and you have exited the installation window, you will be 
able to open Stockbook and begin setting it up for use. 

 Go to your desktop and click on the Stockbook icon. 
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1.2 Registration 
 

To register your purchased copy of Stockbook after installation: 

 Enter your Practical Systems Client ID and website Password (not case sensitive). Note: 
Password is usually the account holder’s first name. 

 Click on the Register Now button.  

 

This will register the program and you will be able to start using Stockbook. 

 

  
 

 

 Click Yes to Confirm message: ‘It appears that you haven’t setup Stockbook yet (you have 
not property defined). Would you like to open the quick start guide?’ 

 

 Click Yes to Confirm message: ‘Would you like to use the setup wizard to help you setup 
Stockbook? Note that you can start the setup wizard at any time by selecting SNetup/Setup 
Wizard from the main menu.’ 

 

Go to: 3.1 Options for Initial Stockbook Setup, Option One – Use the Setup Wizard 
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2 Finding help when you need it 
 

Help and Electronic Documents 
 
By going to the Help menu you will find a comprehensive set of resources to assist you. 

 

  Use PS Knowledge Base 

 This is a self-serve online library providing step-by-step instructions on how to use the various 
features of the Stockbook program. 

 Go to the Practical Systems website: www.practicalsystems.com.au. 

 Click on the PS KNOWLEDGE BASE button. 
 

 
 

 Login using your Practical Systems Client ID and password. 

 In the Practical Systems Support window, click on the Stockbook PS Knowledge Base icon. 
 

 
 

 This will take you to PS Knowledge Base window.  

 In the Search: text box, enter one or more keywords to find related documents. OR  

 Click on the drop-down arrow in the Category: text box to select a related topic.  

 Click on the Go button.  

 A list of related knowledge base articles will appear in the list.  

 Click on the article to select.  
 

 

http://www.practicalsystems.com.au/
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 2.1 On Screen Help 
 To summon help from within a particular area of the program relevant to the screen you 

are on: 

 Press the F1 key or click the  button at the bottom right of the screen. 
 
 

 2.2 Demonstration Data 
The Demonstration company data in Stockbook has been created so that you can start 

viewing, editing or manipulating information straight away. This allows you to make entries 

of your own, amend and delete items – for you to explore and understand the features of 

Stockbook. 

 To access the demonstration data go to the File > Other Databases > Demonstration 

Herd/Flock menu option. 
 
 

 2.3 Practical Systems Software Support Desk. 
Keeping your Practical Cover up-to-date entitles you to: 

 access all program upgrades throughout the year.  

 access telephone & technical support which is available during business hours (8.30am to 

5.30pm Monday to Friday AEST), call 1800 624 688. Use of this service is unlimited for your 

period of cover.  

 You can also access the help desk by emailing support@practicalsystems.com.au. 

 

Practical Cover works as follows:  

 12 months of Practical Cover is included in the purchase price of your software program. After 
this period you will receive an invoice for another 12 months of cover. This fee entitles you to 
all of the benefits listed above.  

 If you require assistance and you have allowed your Practical Cover to lapse, you have two 
options:  

1) Pay for technical assistance from our help desk as required. Each support enquiry is $165 per 
hour. 

2) Reinstate your Practical Cover. Cost is backdated and calculated based on when your cover 
expired.  

 It is far more economical and manageable to keep your Practical Cover up-to-date. Upgrades, 
the Data Warehouse and the PS Knowledge Base are only available to clients whose Practical 
Cover is current.  

  



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3 Getting Started 

The two basic steps to get started are: 

Step 1. Enter setup information via the Setup Menu or Setup Wizard;  
Step 2. Enter your animals.  

Don't forget to use Demonstration Herd to assist you to view and/or practice using the program. 

 

The following illustrates how to setup a commercial operation.  If you have purchased the Stud  

edition you will also be required to complete the Part 5 “additional setup for Stud users” in this 

quick start guide. 

Setup is strongly recommended before adding your animals. 
 
Before we proceed, please make sure you are in the Default Database.   

 Click on the File > Other Databases > Default Databases menu option. 

 

 

 Once you are in the default database, select the livestock type that you wish to setup, this can 

be done thought 3 differing options: 
 

 Click on File > Select Livestock Type (or press F5 on your keyboard, or click the down-arrow 
adjacent to the Animals toolbar option).  

 Select a livestock type from the drop-down list. 

 Your main screen of Stockbook will now change to reflect the livestock type you have selected.  
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3.1 Options for Initial Stockbook Setup 
 

There are two methods to choose from for the initial Stockbook setup: 

 
Option One – Use the Setup Wizard 
 

The set up wizard offers a quick way of getting started. You will complete 5 simple (optional) screens 

which allows you to setup basic information such as properties, paddocks, mobs and groups prior to 

adding your animals. Please use this quick start guide to assist you or the full manual for more 

detailed set up information. 

 Click on Setup > Setup Wizard menu option. (or use Ctrl+Alt+Z on your keyboard) 

 

 
 

 Please follow the prompts using this Quick Start Guide to assist you.  Once you have 

entered your basic setup you can use the setup menus to add, edit or delete setup 

information. 

 

 Read the information on the Welcome to the Stockbook Setup Wizard page then click on 

the Next button.  
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Step 1 of 5 – Setup Properties 

 Click in the text box in the Description column. 

 Enter the name of your property.  

 Click on the Tab key on your key board to move to the next text box. 

 Enter the PIC (property identification code). 

 Click on the Add button to enter another property. 

 Click on the Next button to continue. 

Note: It is a requirement for owners of livestock such as cattle, sheep, goats and pigs to have a 

Property Identification Codes (PICs) when trading or moving these livestock. Livestock owners need 

PIC’s to (1) purchase National Livestock Identification System (NLIS) devices; (2) access other nation 

systems such as national vendor declarations or waybills; (3) report movements to the NLIS database. 

This PIC system operates nationally to allow for the tracing of livestock throughout Australia, to assist 

with disease and chemical residue management. 

 

 
 
Step 2 of 5 – Setup Paddocks 
 

 Click in the text box in the Name column. 
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 Enter the name of your first Paddock.  

 Click on the Tab key on your key board to move to the next text box. 

 Click on the drop-down arrow to select the Property name from the list. 

 Area – (in hectares) optional. 

 Date Created – optional.  

 Click on the Add button to add another Paddock. 

 Click on the Next button to continue. 

 

 

 

 

 

 

 

 

For Example: 

 

 

Setup 3 of 5 – Setup Mobs 

 Click in the text box in the Code column. 

 Enter a unique Code. 

 Click on the Tab key on your key board to move to the next text box. 

 Enter the mob name in the Description column. 

 Click on the Tab key on your key board to move to the next text box. 

 Click on the drop-down arrow to select the Species type from the list (e.g. Cattle, Sheep, 

Goats, etc.). 

 Click on the Add button to add another mob. 

 Click on the Next button when you are ready to continue to the next step. 

 

NOTE: WHAT YOU CLASSIFY AS A MOB IS AT YOUR DISCRETION BASED ON YOUR MANAGEMENT 

NEEDS. 

For Example: 
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Step 4 of 5 – Setup Groups 
 

Groups are a convenient method of organising animals outside a paddock or mob grouping. A group 

would normally be set up for a particular management purpose e.g. Registered or Commercial. 

 Click in the text box in the Code column. 

 Enter a unique Code. 

 Click on the Tab key on your key board to move to the next text box. 

 Enter a group name in the Name column. 

 Click on the Tab key on your key board to move to the next text box. 

 Click on the drop-down arrow to select the Species type from the list (e.g. Cattle, Sheep, 

Goats, etc.). 

 Click on the Add button to add another group. 

 Click on the Next button when you are ready to continue to the next step. 

 

NOTE: WHAT YOU CLASSIFY AS A GROUP IS AT YOUR DISCRETION BASED ON YOUR MANAGEMENT 

NEEDS. 
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Step 5 of 5 – Setup General Options 
 

 Enter your Trading Name, i.e. the name will appear on any Stockbook reports that you 

generate. 

 Enter the Commercial animal Id. Prefix. 

 Click on the down arrow to select a Performance Recording System if you are using one. 

 Click on the Finish button. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
For Example: 

 
 
 

Option Two - Entering setup information using the setup menus 
 

 Mobs, groups, properties, paddocks, treatment and products, etc. can be individually set up 

from the drop-down list to save time typing and to speed up data entry. 
 

 

 
 

 Mobs, groups and paddocks can be added on the fly while working within the program by 

utilising the + button as seen in the image below. 
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 We suggest that you set-up most of the initial information from the menu items. This will 

speed-up the adding of animals in the first instance.  



3.2 Setup Backup Preferences 
 

 Before you start working your way through the suggested setup lists, it is important to first 

setup your backup preferences. 

 Backing up is fundamental to managing your Stockbook data. 

 Click on Setup > Backup Preferences menu option. 

 

 

 

 

 Backup prefix – this is automatically generated based on your Client ID. 

 Add comments to backup – Comments can be added to a backup file to distinguish one 

backup from another (apart from date). 

 Verify backups after completion – Stockbook will automatically check the backup file for 
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validity if this box is ticked. 

 Auto backup on exit from Stockbook – tick this to get Stockbook to automatically backup 

files on exit from the program.  

 Backup Location (eg “a:” drive) – click on the yellow open folder icon to search for and 

indicate to Stockbook where you would like the backup file to be kept. It is highly 

recommended that you set this location to an external backup medium e.g. a USB, external 

hard drive, etc. (Note: you do not need to set this location if you are using the Data 

Warehouse) 

 Copy Location (a folder on the hard drive) – this is automatically generated. 

 Data Warehouse Admin – click on this button. See section 3.2.1 on completing your Data 

Warehouse setup.  
 

 

 
 

 
Backing up is vital and cannot be over-emphasised please see section 3.5 for how to backup. 

 
 

3.2.1  Data Warehouse Setup 
 
Backing up your data is the most important part of using Practical Systems software. It is also 

important to have a Backup that is external to your computer and possibly even in another location 

away from your office or home, in case of any unforseen event. 
 

The Practical Systems Data Warehouse is a secure, off-site data storage service, located on the 

Practical Systems server. 
 

 To set up your Data Warehouse within Stockbook: 

  Click on Setup > Backup Preferences menu option. 

 Click on Data Warehouse Admin button. 

 Click OK to the following Information message:  
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 The first time you login, your password will be YOUR Practical Systems CLIENT ID. You will 

then be prompted to change your password. 

 

 Enter a password. 

 Enter the same password to confirm.  

 Click OK button. 

 

 



 You can change your password at any time by logging into Data Warehouse through this function. 
You can also view the backups that are currently stored in the data warehouse as well.  
These can both be done by selecting one or the other from the drop down list as shown below 
and clicking on the Go button. 
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3.3 The Setup Menus 


 The suggested lists to setup prior to adding your animals are outlined below. Keep in mind any 

items can be added on-the-fly by using the plus button next to the drop down list on the 

appropriate screens. 

 

Each setup list follows the same basic rules and allows you to do the following:  

 

 Add an item: 
 

 Click on Setup and then select desired menu option from the list (e.g. Setup > Mobs). 

 Click on Add button. 

 Enter a (unique) code (if code required) and description. 

 Click on OK to accept the data and prepare for another entry, or click on Cancel/Exit to close the 
screen without any changes to the database. 

 

 Edit an item: 

 Click on Setup and then select desired menu option from the list (e.g. Setup > Mobs). 

 Click to highlight the item to be edited.  
 Click on Edit button. (or double click on the item.) 
 Modify details as required, or make inactive (for items you no longer want to appear in the 

list). 
 Click on the OK to accept the data, or click Cancel/Exit to abort data entry. 

 

 Delete an item: 

 Click on Setup and then select desired menu option from the list (e.g. Setup > Mobs). 
 Highlight to select the item to be deleted. 
 Click on the Delete button. 

 Confirm the deletion. 

 

Note: You cannot delete an item that still contains at least one active animal within the selected list. 
 
 

3.3.1  Setup Mobs 
 

 Mobs are a convenient method of organising animals, normally corresponding to physical 

mobs in paddocks.  A mob can, however, be split over several paddocks, and can be used as 

a wider grouping method than a paddock. 
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You may choose to setup your mobs as it suits you. (e.g. sale bulls, young bulls, autumn calves, 

Rams etc.) or use the year drop as the mob name.  It’s purely a personal preference, but keep in 

mind how you would like to find/search for these animals in the future by using the filter 

within Stockbook. The filter allows you to filter/search on criteria such as mob, group, 

paddock through to more advanced criteria such as weights, carcass feedback, and fleece data.  

 
 

Animals can be in several different mobs or groups over their lifetime but can only be in one mob 

or group at any one given time.  You can make a mob inactive or delete it.  If you wish to view 

inactive mobs tick include inactive box in the mob setup list area. 

Note: A mob cannot be made inactive or deleted if there are currently active animals in that 
mob. 

 
3.3.2.   Setup Groups 
 
 Groups are a convenient method of organising animals outside a paddock or mob.  A 

group could be set up for a particular management purpose e.g. breeding cows, sale bulls 

etc.  You may decide not to put animals into a group initially and only move some into a 

group if the need arises at a later date. 

For Example: 
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Groups can be added, edited, deleted or made inactive by going to Setup > Groups menu 

option and following the steps outlined in section 3.3. 

 

 

3.3.3.  Setup Properties 
 

 Every animal on file can be assigned to a paddock. Every paddock must be linked to a 
property. 

 

 Go to Setup > Properties menu option. From this display you can: 
A list of active properties will be displayed. To include inactive properties, tick the Include 
Inactive box.  From this display you can: 

Add a new property, Edit a property or Delete a property. 
 

 
 

3.3.4  Setup Paddocks 
Paddocks relate to a physical paddock, however if you do not wish to use paddocks you can 

add a paddock that has the same name as your property so that animals are still allocated to 

a property within your database. This is important for NLIS records. 

Paddocks are used to record paddock treatments from a quality control perspective, animal 

grazing history and assist with filtering and reporting. 
 

 

 Click on Setup > Paddocks menu option. (or click on the Paddocks toolbar icon) 
 From this display you can: 

Add a new Paddock, Edit a Paddock, Delete a Paddock or Add Paddock Treatments. 
 

 

 
 

 

 Add a new paddock 
 

 Click on the Add button.  

 Enter a Name, link the paddock to a Property using the drop down list, enter the Area (if you 
wish) and the creation date.  

 Click on the OK to accept the data, or click Cancel/Exit to abort data entry. 
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 Edit a Paddock 
 

 Click on the Edit button on the main paddocks screen.  

 Edit any details required. 

 Click on the OK to accept the data, or click Cancel/Exit to abort data entry. 
 

 

 Delete a Paddock 
 

 Select a paddock from the paddocks list, so that it is highlighted a dark green.  

 Click on the Delete button.  
 Click Yes to Confirm message: ‘Delete paddock ……..’ to delete paddock. 

 
 

 Making a Paddock Inactive 
 

 Select the paddock from the list so it is highlighted dark green.  

 Click on the Edit button. 

 Tick the Inactive box. 

 Click on the OK to accept the data, or click Cancel/Exit to abort data entry. 
 
 

 Treatments 
 

 Click on the paddock whose treatment you want to see or update. (Note: a highlighted dark 
green means paddock is selected).  

 Click on the Treatments button. 

 Click on the Add button. 

 Enter the following details: 
o Treatment date (in dd/mm/yyyy format or pick from calendar). 
o Treatment – select from dropdown list or add a new paddock treatment to the list via 

the + button. (See 3.3.5 Setup Treatments) 
o Product – select from the dropdown list of products available for the specified 

treatment or add a new product to the list via the + button. If you want to use a product 
that has been assigned to a different treatment, turn off the box marked Restrict 
Product List. (See 3.3.6 Setup Products) 

o Application Rate of product used.  
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o Units – are determined by the specified product. 
o Dilution rate of the product for the treatment. 
o Batch No. – of the product used. You can add a new batch to the list via the + button. 
o Comment 
o Qty Used – quantity of the product used in the treatment. 

 

 Click on the OK to accept the data, or click Cancel/Exit to abort data entry. If the transaction is 
accepted and you have entered a batch number and quantity used, then the stock on hand of 
that batch will be updated. 

 

 
 
 

3.3.5  Setup Treatments 

 Treatments are operations carried out on animals or paddocks where a specific product is 

used.  A description of the treatment type must be setup before they can be used. 
 
 

Animal Treatments 

Define your own treatment names for animal treatments.   We suggest using a general description 

rather than a treatment method. E.g. ‘Internal Parasites’ rather than ‘Drench’; or ‘External Parasites’ 

rather than ‘Pour-on’; ‘Vaccination’ rather than ‘5 in 1’etc. You will set up the specific products at a 

later stage. 

 

 Click on Setup > Treatments > Animal menu option. From this display you can: 

 

Add a treatment, Edit a treatment or Delete a treatment. 

 You can add a treatment by clicking on the Add button at the bottom of the screen and entering 
a description.  

 Click on the OK to accept the data, or click Cancel/Exit to abort data entry. 
.  
 
A treatment can be edited or deleted by selecting it in the list so it is highlighted blue and selecting Edit 
or Delete.  
 
Note: Once a treatment has been assigned to an animal at any stage it will not be able to be deleted.  
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Paddock Treatments 

Define your own treatment names for paddock treatments.  Again we suggest using a general 

description rather than a treatment method. E.g.  ‘Weed Control’ rather than ‘Spray’. 

 

 Click on Setup > Treatments > Paddock menu option. From this display you can: 

 

Add a treatment, Edit a treatment or Delete a treatment. 

 To Add, Edit or Delete paddock treatments, follow the same steps as above that were 
completed for the animal treatments. 

 
For example: 
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3.3.6  Setup Products 

 

 

 It is essential to enter the products that are used within the treatments that were set up in 
section 3.3.5. These products can be entered via the setup menu and linked to the previously 
setup treatments. 

 

  Click on Setup > Products or Products > Setup menu options. Both will take you to the same 

Products screen. 

 From this display you can:  Add a new product, Edit a product or Delete a product. 

 



 

 When adding a new product, select the Type of product it is (a Vet. Product is all vaccines/drenches 
etc.) and enter all other details of that product.  

 To link it to a treatment select the appropriate treatment from the dropdown list in the Used in 
Treatment section.  

 Click on the OK button to accept the data.  
 

 This product can be edited or deleted at a later date. However if the product is no longer in use it is 
recommended that it is made inactive by ticking the Inactive box when editing the product.  

 

 
 



27 

© <2018> … Practical Systems 

 

 

  
Note: After you add the withholding period in days, whenever that product is applied during a treatment the 

withholding period is added to the treatment date, giving a release date.  The animal or paddock will be 

displayed in red text indicating it is in a withholding period.  An attempt to sell this animal  will  give  a  

warning,  as  will  attempting  to  move  animals  into  a  paddock  that  is  in  a withholding period. 

 

3.3.7  Product Purchases 

Products can be entered with batch numbers and quantity on hand to assist you in keeping an inventory 

of the chemicals and treatments on your property. This setup is essential if you are participating in a QA 

program.  

 Click on Setup > Product Purchases or Products > Product Purchases menu option. 

This will bring up a list of products that are currently on hand. You can Add, Edit and Delete products in 

this section. They will all need to be linked to an existing treatment/product.  





 Add a Product Purchase 

 Click on the Add button at the bottom of the screen.  

 Enter all details relating to the product.  
If the product does not have a batch number Stockbook will generate a batch number 
automatically within the program.  

 Once all of the details have been entered, click on the OK button to save.   
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 Products can be edited and deleted at any point in time however once a specific product has 

been used against an animal that is not advised.  

 Note: This step does not need to be completed in the initial setup but is important to keep track of 

your chemical and treatment stocks in the future. 

 

3.3.8 Setup Veterinary Activities 

 Veterinary Activities relate to procedures that are of a general nature and do not require the 

use of a product. (E.g. Brucellosis Testing, Eye Operation, Feet Trimming).  You can define as 

many different activities as you like. 

 Click on Setup > Veterinary Activities menu option. 

 From this display you can: Add a new veterinary activity, Edit a veterinary activity or Delete a 

veterinary activity. 

 

 

3.3.9  Setup Cost Events 
 

 Cost Events are descriptions that you can setup as standard descriptions for recording 

animal costs, e.g. Transport, yard dues, commissions etc.  You will notice there is already an 

extensive list setup in this area of the program. 

 

 Click on Setup > Cost Events menu option. 

 From this display you can: Add a new cost event, Edit a cost event or Delete a cost event. 

 You will note that only a description can be entered in this list. When this cost is applied to a 
specific animal or group of animals the price itself and further details can be applied. 
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3.4 Setup User Options 

User options allow you to customise parts of Stockbook. 

 Click on Setup > User Options menu option. 

The six user option tabs are: 
   General 
   Options 
   Screen 
   User Fields 
   Colours 
   Animal Display 
 
Suggested areas to setup initially are: 

 Go to General tab – Enter your trading name.  This is the name you would like to appear at 

the top of any reports generated through Stockbook. 

Installation type must be set on “Normal User” (Both for Stud and Commercial users) unless 

the program is being operated by a Breed Society. E.g. You are an actual Breed Society. 

Performance Recording System is only used if you submit data to a performance recording 

system. 

 Go to Options tab – select your preferences by ticking or unticking the boxes. 

 Go to User Fields tab – This allows you customise/change the labels on the ‘Main Animals’ 

screen. It is advisable to keep alternate ID and NLIS ID as is.  

Enter Colours in between the User Fields and Animal Display tab.  

 Go to User Colours tab - This allows you to change the colours for the buttons within 

Stockbook and set colours for the highlight of animals. This is not essential or advised to be 

changed as you are first setting up the program.  

 Go to Animal Display tab – This allows you customise your main animal display screen. 

Put a tick in the box beside each field you would like to have displayed. 
Once you have completed the choice of the fields you would like displayed, click on the OK 
button. 

 
 

Note: The weight option displays the last weight taken for that animal. The Micron option (for 
sheep producers) displays the last Micron measured. 

 

Note: If you will be using Stockbook for a stud operation please complete section 5 of this guide 
before adding your animals. 
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3.5 Backing Up 

  As referred to previously backing up is an important process in ensuring your data is not lost at 

any point.  
We advise completing a backup following the steps below before adding new animals into your 
program. 

 

Steps to completing a backup: 

 

 Click on the File > Backup Database menu option. 

 

 
 

 

 Select a location to save the backup to if you would like it saved in another location other than the 
default.  

 Click on the Fix button to generate a backup name.  

 Tick Send this file to the Practical Systems Data Warehouse upon completion if you would also like 
to send it to the Data Warehouse.  

 Click on the Backup button. 

 Your backup will now be completed and sent to the selected location.  

 

 

 
 

 If you chose to Send a copy of the backup to the Practical Systems Data Warehouse: 

 Click OK to the information message: ‘Backup completed’ to complete the local backup. 

 Click OK to the Information message: ‘You will now be asked to login to the data 

warehouse server. Once logged in your backup will be uploaded.’ 

 You will be required to login to the Data Warehouse using you Client ID and Password 
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(the first time you login your password will be you Client ID, and you will be prompted to 

set a new one, see section 3.2.1) 

 

 
 

 You now have the option to Password Protect the backup, this is completely optional. 

 Click Next to continue. (Note: if you forget this password, Practical Systems cannot help you 
retrieve this backup.) 

 

 
 

 

 Enter a backup file description, such as the date of the backup or the activity that 

you completed in Stockbook that session. 

 

 
 

 Click OK to the Information message: ‘The File has been successfully uploaded to the server.’ 
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3.6 Restoring a Backup 

 In the event of things going pear shaped, you can simply restore your backup that you made prior 

to your changes. 
However be aware that restoring a backup will overwrite all data currently in the program and it 
will not be able to be retrieved if it was wrongly overwritten.  
 
 
To restore a backup: 

 Click on the File > Restore Database menu option. 
 

 
 

 
To Restore from a local folder: 

 Get backups from – click on a local folder … radio dial to select. 

 Click on the backup file to be restored (the most current is at the top of the list.) 

 Note: the selected file will be highlighted blue. 

 Click on the Restore button. 
 

 
 

 Click Yes to the following Confirm message (or something similar): 
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 Click OK to the Information message: ‘Restore completed’ 
 

To Restore from the Practical Systems Data Warehouse: 

 

 Get backups from – click on Data Warehouse radio dial to select. 

 Click on the Restore button. 

 In the PS Login window enter your Client Code and Password, then click on the OK 
button. 

 Click on the most recent backup (which appears at the top of the list) to select. 

 Note: the selected file will be highlighted blue. 

 Click on the OK button. 
 

 
 

 Click OK to the Information message: ‘The File has been successfully downloaded from 
the server.’ 

 Click Yes to the following Confirm message (or something similar): 
 

 
 

 Click OK to the Information message: ‘Restore completed’ 
 

 













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

4 Adding your animals Into Stockbook 

 There are various methods of adding your existing animals for the first time.   The 

following illustrates how to manually add animal details. 

 For a full list of methods for adding animals refer to section 4.2 of this quick start 

guide. 
 

4.1 Manually Adding Animals into Stockbook 
 

There are a few options for manually adding animals: 

Option one – Use the Add button from the main animal screen (see section 4.1.1) 

Option two – Use the Add animal wizard (see section 4.1.2) 

Option three – Use  Multi-Add (see section 4.1.3) 
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4.1.1 Using the Add button 

 The Add button allows you to enter as little or as much information as you require.  

 If you do not enter a Primary ID ( Visual ID) Stockbook will generate one for the 
animal. 

 
 

Note: If the dam and sire are not animals in Stockbook already they will not be able to be added in the animal 
details initially. 

 

 

4.1.2 Using the Add Animal Wizard 

 The add animal wizard steps out the process of adding an animal over a series of 

4 screens.  If you do not add a primary Id (VID), Stockbook will generate one for you. 

 

 
 

Note: If the dam and sire are not animals in Stockbook already they will not be able to be added in the animal 
details initially.
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4.1.3 Using the Multi-Add 

  Multi-Add allows you to add a number of animals either by allocating a 

specific 

Visual ID range or by retrieving tag numbers from an unallocated 
tag list. 
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4.2 Methods for Entering Animals into Stockbook 

 As mentioned, there are various methods of adding your existing animals for the 

first time. The following table illustrates the various options for entering animals into 

Stockbook. Use this table to help you decide the easiest way to enter your animals based 

on your type of operation, equipment and animal information you have. 

The manual entry methods are a slower process of adding animals, so if any of the 

below apply to you please contact Practical Systems support team or go onto our online 

knowledge base for more information. 

Method of entry into 

Stockbook 

Equipment Needed Recommended for Ease of use 

Manual Data Entry via 
the add animal, add 
animal wizard or Multi 
add screen. Starting at 
your oldest animal first. 

Stockbook, computer, 
Visual Id numbers and 
animal details. 

This method is recommended for 
small herds/flocks. 

Easy 

Data Extraction from 
your 

Breed Society. 

Data Extraction forms 
are available from 
Practical Systems. 

This method is recommended for 
setting up Stud animals. 

Easy 

CSV Import or import 

from data collector file. 

Stockbook, Computer, 
Excel file converted to a 
CSV file or data collector 
file. 

If you have animal information in 

excel spread sheets (note this will 
need to be saved as CSV files 
before importing into Stockbook. 
You can also import files that 
been created from data collectors. 

Moderate 

knowledge 
of excel & 
CSV files 
required. 

Import data direct from 

collector 

Stockbook, Computer, 

Data collector. 

This allows you to import direct 

from your weigh scales. 

Moderate 
knowledge of 
hardware 
required. 

Transfer data from 
reader 

Stockbook, Computer, 

Reader with storage. 

This allows you to add animals by 

downloading direct from your 

reader. 

Moderate 
knowledge of 
hardware 
required. 

Using the laptop screen Stockbook & laptop 
computer to use in yards. 
readers and scales can be 
directly plugged into the 
laptop but are not 
essential for using the lap 
top screen. 

This option offers a quick effective 

method of adding animals. 

Ability to 
operate lap 
top computer 
and hardware 
in the yards. 

Download a tag bucket 

file from NLIS database 

Stockbook, Computer with 
internet access. 

This method allows you to 
download existing animals and 
unassigned tags assigned to your 
PIC  from the NLIS database. This 
information can then be imported 
into Stockbook. 

 

Moderate 
knowledge of 
Stockbook & 
the NLIS 
database. 

 
 

Note: These methods are all effective in adding your animals into the program. A combination of these methods 
may be the best option for your operation. Please contact us for more assistance and further information if 
required. 
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4.3 Animal Types 

Once your animals are entered your animals into Stockbook they can be seen by clicking on the 

Animals icon. 

 
 

 

There are three types of animals in Stockbook. Current, Inactive and Archived. Please refer 
below to determine the appropriate status of your animals: 

1.   Current Animals - The current animals are ones on your farm at this moment. 

2.   Inactive Animals - The inactive animals are those animals that have been disposed 

of, (either sold or died). You can still view these animals on the main data base, look 

up their history and include them in reports.  These animals can be viewed by ticking 

the Include Inactive box at the bottom of the main animals screen. Animals that are 

entered on the database for pedigree only purposes will also be marked as inactive 

animals. 

3.   Archived Animals - Animals that have been made inactive can be archived. This 

procedure removes the animals from the current animal list and moves them to an 

archived database. The benefit of this procedure is to reduce your current animal 

list.  Archived animals can be returned to the current animal list if needed. 
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5 Additional Setup for Stud Users 
 

 This additional setup is done primarily to facilitate the transfer of data to and from 

Sheep Genetics, ABRI and Breed Societies. 

We have outlined the necessary steps to enable this function. 
 
 

5.1 Society and Stud Setup for Stud Cattle 

 Complete the steps below to enable data import and export between Stockbook, your Breed 

Society and ABRI. 

 

 Click on the Setup > User Options menu option. 

In the General tab, fill out the applicable details as shown in steps 1 – 4 below. 

 Current Animals - The current animals are ones on your farm at this moment. 

 Trading Name – This is the name that will appear at the top of all your reports. 

 I am a …. Normal User 
   Breed Society 

 QA Accred. No. – Quality Assurance (Cattle Care) Accreditation Number. 

 QA Expiry Date – Qualtity Assurance (Cattle Care) accreditation expiry date. 

 Performance Recording System – If you submit data to a performance recording 
system, you specify the system that you use. E.g. Breedplan. 

 Commercial animal Id Prefix – If you want the Primary Id. for all commercial animals to 
start with a common set of characters, you can enter that prefix here. 

 Password Protect – If you want to prevent unauthorized access to your Stockbook 
data, you can define a password that must be entered every time Stockbook is started. 
Tick the “password protect” box and enter a password. You will need to verify the 
password.  
If you ever want to remove password protection, just untick the “password protect” 
box. 

 Enable Auditing – Auditing records every change that a user makes within Stockbook. 
This is only useful if you have multiple users setup and you wish to keep check of the 
changes made by each user. 

 I am using …  NLIS (National Livestock Identification System) - Australia 
NAIT (National Animal Identification & Tracing) New Zealand 

 

In the Options tab, it is advised to review your settings.  

 Tick the following boxes that are applicable.  

 Click on the Help button  for further explanation of check box options. 

 

 Click OK to save selection.  
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Click on the Setup > Society Details menu option. 

Enter this below the first line please:  

 Choose a Society from the drop down box if you have purchased the stud version of 
Stockbook. 

 Enter your Society Email details - this will be necessary for data transfer.  

 Enter your Herd Ident. This is the identification that will be assigned to your animals 
Society ID if auto-calculated by Stockbook.  

 Enter your Correspondence/Membership No.  

 Enter the Animal Name Prefix this is normally used as the first part of the name of any 
new animal that you enter into your system. These are characters that are allocated to 
you by your society. 

 Select the Breed from the drop down list.  

 Tick the following boxes that are applicable to you and ensure that they are according 
to your society's requirements.  

 Click on the OK button.  

 

Note: If you choose for Stockbook to auto-calculate the society IDs it will calculate them based off the 

visual ID.  

 
 
 



41 

© <2018> … Practical Systems 

 

 

 

5.1.2  Setup Performance Recording for Cattle 

 Stockbook gives you the flexibility of setting up your program for any trait analysis system (e.g. 
EBV’s, EPD‘s etc.). However, to do that it requires you to tell it which system you are using and 
which values you want used with their names. 

 Complete the steps below to Setup your Trait Analysis System for Cattle. 
 

 Click on the Setup > Performance > Trait Analysis System menu option. 
 

 
 

 Click Set Standard Breedplan at the bottom of the screen. This will default your traits to those 
used by Standard Breedplan.  

 Select the EBVs and breed objects you require by ticking the Use box in the column.  

 Select Estimated Breeding Values from the drop down box for the Trait Analysis system. 
 

 

 

Note: you must select a minimum of one and a maximum of 19 EBV’s, at least one Breed Object and a 
maximum of 6. 
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This completes the Society and Stud Cattle Setup 
 

 
 

5.2 Flock and Performance Recording Setup for Stud Sheep 

 Please complete the steps below to enable data the transfer of data between 

Stockbook, Sheep Genetics and your Breed Association. 

 

 Go to the Setup > User Options menu option and follow steps 1-5 filling out the details. 

On the General tab, fill out the applicable details as shown in steps 1 – 4 below. 

 Current Animals - The current animals are ones on your farm at this moment. 

 Trading Name – This is the name that will appear at the top of all your reports. 

 I am a …. Normal User – select this option. 
   Breed Society 

 QA Accred. No. – Quality Assurance Accreditation Number. 

 QA Expiry Date – Qualtity Assurance accreditation expiry date. 

 Performance Recording System – If you submit data to a performance recording 
system, you specify the system that you use. E.g. SG (Sheep Genetics). 

 Commercial animal Id Prefix – If you want the Primary Id. for all commercial animals to 
start with a common set of characters, you can enter that prefix here. 

 Password Protect – If you want to prevent unauthorized access to your Stockbook 
data, you can define a password that must be entered every time Stockbook is started. 
Tick the “password protect” box and enter a password. You will need to verify the 
password.  
If you ever want to remove password protection, just untick the “password protect” 
box. 

 Enable Auditing – Auditing records every change that a user makes within Stockbook. 
This is only useful if you have multiple users setup and you wish to keep check of the 
changes made by each user. 

 I am using …  NLIS (National Livestock Identification System) - Australia 
NAIT (National Animal Identification & Tracing) New Zealand 

 

In the Options tab, it is advised to review your settings.  

 Tick the following boxes that are applicable.  

 Click on the Help button  for further explanation of check box options. 

Click OK to save selection. 
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5.2.1 Setup Flock Details 
 

 Click on the Setup > Flock Details menu option.  

 Click on the Add button. 

 Enter your Flock Name. 

 Enter your Flock Ident – this will be your 4 digit Sheep Genetics code. 

 Select you breed from the drop-down list. 

 Click OK to save. 

 

 
 

 If you are registering your lambs with a Breed Association please continue. 

 
 

5.2.2 Setup Flock Society Details 
 

 While still in Flock Details, select the Flock to setup society details for, so that it is highlighted 
blue. 

 Click on the Edit button. 
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  Fill out the Animal Name Prefix (optional) and tick the Tick this box if this flock is registered 
with ABRI box if applicable. 

 
 
 

  After ticking the Tick this box if this is registered with ABRI check box, you will need to enter 
any specific options for your society.  

 Enter your ABRI Ident. - which is your three letter prefix.  

 Tick any boxes that are applicable to you and your society.  
 
Note: By ticking auto calculate society IDs, Stockbook will calculate your SGID based off your Visual ID, 
birth date and other society information you have entered.  
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5.2.3  Setup Performance Recording for Sheep 

 Complete the steps below to Setup your Trait Analysis System for Sheep. 

 Click on the Setup > Performance > Trait Analysis System menu option. 

 
 

 

  Complete the following steps: 

 Click Set Standard Lambplan button at the bottom of the screen. This will default your traits to those 
used by Standard Lambplan. 

 Select the ASBVs and breed objects by ticking the Use box in the column.  

 Select Australian Sheep Breeding Values from the drop down box for the Trait Analysis System. 

 Click on the OK button.  
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

Note: you must select a minimum of one and a maximum of 19 ASBV’s, at least one Breed Object and 
a maximum of 6. 



 

This completes the setup for Stud Sheep 
 
 
 
 
 
 
 

You have now completed the setup of your Stockbook 

program and can now begin to utilise the program to 

manage your livestock data.  

 

Please contact the support team on 1800 624 688 for any 

further questions or access our online knowledge base on 

our website.  



 

 

 


